burp-ui 0.6.2 has dependency issues with Python 3.6 and CentOS 7
I run python 3.6 on my CentOS box since Python 2 & 3.4 are mostly EOL (installed via yum install python36-pip) Just tried to upgrade burp-ui to latest pip release (seems to be 0.6.3):
python36 -m pip install burp-ui burp-ui-agent
Everytyhing installed, but I get: burp-ui-agent 0.6.3 has requirement arrow==0.12.0, but you'll have arrow 0.13.0 which is incompatible.
When trying to stick to latest 'official' release:
python36 -m pip install burp-ui==0.6.2 burp-ui-agent==0.6.2
I get the same issue: burp-ui-agent 0.6.2 has requirement arrow==0.12.0, but you'll have arrow 0.13.0 which is incompatible.
If I happen to install arrow 0.12.0, I get the following:
python36 -m pip install arrow==0.12.0 Collecting arrow==0.12.0 Using cached https://files.pythonhosted.org/packages/90/48/7ecfce4f2830f59dfacbb2b5a31e3ff1112b731a413724be40f57faa4450/arrow-0.12.0.tar.gz Requirement already satisfied: python-dateutil in /usr/local/lib/python3.6/site-packages (from arrow==0.12.0) (2.8.0) Requirement already satisfied: six>=1.5 in /usr/local/lib/python3.6/site-packages (from python-dateutil->arrow==0.12.0) (1.11.0) burp-ui 0.6.2 has requirement arrow==0.13.0, but you'll have arrow 0.12.0 which is incompatible.
Guess there's just a mix of requirements.txt :)
I don't know if arrow 0.13.0 would work. But in any case, I guess a lot of CentOS 7 users will have this message.