tweaks for release

3 jobs for 291-support-burp-2-2-16-2 in 60 minutes (queued for 8 seconds)
Status Job ID Name Coverage
  Test
failed #5665
lint
test:lint

00:02:24

failed #5666
docker
test:py2.7

01:00:00

failed #5667
docker
test:py3.6

01:00:00

 
Name Stage Failure
failed
test:py3.6 Test The script exceeded the maximum execution time set for the job
$ tox -e py36
GLOB sdist-make: /ziirish/burp-ui/setup.py
py36 create: /ziirish/burp-ui/.tox/py36
py36 installdeps: .[ci]
py36 inst: /ziirish/burp-ui/.tox/.tmp/package/1/burp-ui-0.6.1.zip
py36 installed: alembic==1.0.7,amqp==2.4.1,aniso8601==4.1.0,arrow==0.12.0,asn1crypto==0.24.0,Babel==2.6.0,billiard==3.5.0.5,burp-ui==0.6.1,celery==4.2.1,cffi==1.11.5,Click==7.0,configobj==5.0.6,coverage==4.5.2,cryptography==2.5,Flask==0.12.4,Flask-Babel==0.11.2,Flask-Bower==1.3.0,Flask-Caching==1.4.0,Flask-Login==0.4.1,Flask-Migrate==2.3.1,flask-restplus==0.10.1,Flask-Session==0.3.1,Flask-SQLAlchemy==2.3.2,Flask-Testing==0.7.1,Flask-WTF==0.14.2,itsdangerous==1.1.0,Jinja2==2.10,jsonschema==2.6.0,kombu==4.3.0,Mako==1.0.7,MarkupSafe==1.1.0,mock==2.0.0,mockredispy==2.9.3,nose==1.3.7,pbr==5.1.2,pluginbase==0.5,pyasn1==0.4.5,pycparser==2.19,pyOpenSSL==19.0.0,python-dateutil==2.8.0,python-editor==1.0.4,pytz==2018.9,redis==3.1.0,six==1.11.0,SQLAlchemy==1.2.17,SQLAlchemy-Utils==0.33.11,tzlocal==1.5.1,vine==1.2.0,Werkzeug==0.14.1,WTForms==2.1
py36 run-test-pre: PYTHONHASHSEED='2979815148'
py36 runtests: commands[0] | nosetests --with-coverage --cover-package=burpui tests/test_burpui.py
................................
ERROR: Job failed: execution took longer than 1h0m0s seconds
failed
test:lint Test
burpui/api/client.py:900:75: W504 line break after binary operator
burpui/api/client.py:996:75: W504 line break after binary operator
burpui/api/client.py:1095:75: W504 line break after binary operator
burpui/api/custom/my_fields.py:156:40: W504 line break after binary operator
burpui/api/custom/my_fields.py:157:48: W504 line break after binary operator
burpui/api/custom/namespace.py:32:64: W504 line break after binary operator
make: *** [flake8] Error 1
Makefile:31: recipe for target 'flake8' failed
ERROR: Job failed: command terminated with exit code 1
failed
test:py2.7 Test The script exceeded the maximum execution time set for the job
$ tox -e py27
GLOB sdist-make: /ziirish/burp-ui/setup.py
py27 create: /ziirish/burp-ui/.tox/py27
py27 installdeps: .[ci]
py27 inst: /ziirish/burp-ui/.tox/.tmp/package/1/burp-ui-0.6.1.zip
py27 installed: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.,alembic==1.0.7,amqp==2.4.1,aniso8601==4.1.0,arrow==0.12.0,asn1crypto==0.24.0,Babel==2.6.0,backports.functools-lru-cache==1.2.1,billiard==3.5.0.5,burp-ui==0.6.1,celery==4.2.1,cffi==1.11.5,Click==7.0,configobj==5.0.6,coverage==4.5.2,cryptography==2.5,enum34==1.1.6,Flask==0.12.4,Flask-Babel==0.11.2,Flask-Bower==1.3.0,Flask-Caching==1.4.0,Flask-Login==0.4.1,Flask-Migrate==2.3.1,flask-restplus==0.10.1,Flask-Session==0.3.1,Flask-SQLAlchemy==2.3.2,Flask-Testing==0.7.1,Flask-WTF==0.14.2,funcsigs==1.0.2,functools32==3.2.3.post2,ipaddress==1.0.22,itsdangerous==1.1.0,Jinja2==2.10,jsonschema==2.6.0,kombu==4.3.0,Mako==1.0.7,MarkupSafe==1.1.0,mock==2.0.0,mockredispy==2.9.3,nose==1.3.7,pbr==5.1.2,pluginbase==0.5,pyasn1==0.4.5,pycparser==2.19,pyOpenSSL==19.0.0,python-dateutil==2.8.0,python-editor==1.0.4,pytz==2018.9,redis==3.1.0,six==1.11.0,SQLAlchemy==1.2.17,SQLAlchemy-Utils==0.33.11,tzlocal==1.5.1,vine==1.2.0,Werkzeug==0.14.1,WTForms==2.1
py27 run-test-pre: PYTHONHASHSEED='2791000371'
py27 runtests: commands[0] | nosetests --with-coverage --cover-package=burpui tests/test_burpui.py
................................
ERROR: Job failed: execution took longer than 1h0m0s seconds