Commit bcbbecaf authored by Ziirish's avatar Ziirish

update requirements and changelog

parent f349caa8
Pipeline #1383 failed with stages
in 3 minutes and 54 seconds
......@@ -79,7 +79,7 @@ build:doc:
- wget https://bitbucket.org/birkenfeld/sphinx-contrib/get/8e295053a27d.zip
- unzip 8e295053a27d.zip
- (cd birkenfeld-sphinx-contrib-8e295053a27d/httpdomain/ && python setup.py build && python setup.py install)
- pip install -r docs/requirements.txt
- pip install -U -r docs/requirements.txt
- make doc
tags:
- build
......
......@@ -8,6 +8,7 @@ Current
- **BREAKING**: the *Burp1* and *Burp2* configuration sections have been merged into one single *Burp* section
- **BREAKING**: the *running* backups are now displayed in ``green`` instead of ``blue``
- **BREAKING**: the docker postgresql image was upgraded from 9.6 to 10.1, you'll have to manually upgrade/migrate your data `following this documentation <https://github.com/tianon/docker-postgres-upgrade>`_
- **BREAKING**: the ``docker-compose.yml`` file now uses the ``version: '2'`` format
- Add: new plugins system to allow users to write their own modules
- Add: `Italian translation <https://git.ziirish.me/ziirish/burp-ui/merge_requests/74>`_ thanks to Enrico
- Add: new `client configuration templates <https://git.ziirish.me/ziirish/burp-ui/issues/155>`_
......@@ -29,6 +30,12 @@ Current
- Fix: issue `#236 <https://git.ziirish.me/ziirish/burp-ui/issues/236>`_
- Fix: issue `#242 <https://git.ziirish.me/ziirish/burp-ui/issues/242>`_
- Fix: issue `#245 <https://git.ziirish.me/ziirish/burp-ui/issues/245>`_
- Fix: issue `#246 <https://git.ziirish.me/ziirish/burp-ui/issues/246>`_
- Fix: issue `#247 <https://git.ziirish.me/ziirish/burp-ui/issues/247>`_
- Fix: issue `#248 <https://git.ziirish.me/ziirish/burp-ui/issues/248>`_
- Fix: issue `#251 <https://git.ziirish.me/ziirish/burp-ui/issues/251>`_
- Fix: issue `#257 <https://git.ziirish.me/ziirish/burp-ui/issues/257>`_
- Fix: issue `#262 <https://git.ziirish.me/ziirish/burp-ui/issues/262>`_
- `Full changelog <https://git.ziirish.me/ziirish/burp-ui/compare/v0.5.0...master>`__
0.5.1 (05/26/2017)
......
Flask==0.12
Flask-Login==0.4.0
Flask==0.12.4
Flask-Login==0.4.1
Flask-Bower==1.3.0
Flask-Babel==0.11.2
Flask-WTF==0.14.2
flask-restplus==0.10.1
Flask-Caching==1.3.2
Flask-Caching==1.4.0
WTForms==2.1
arrow==0.10.0
arrow==0.11.0
pluginbase==0.5
tzlocal==1.4
six==1.10.0
pyOpenSSL==17.2.0
tzlocal==1.5.1
six==1.11.0
pyOpenSSL>=17.5.0
configobj==5.0.6
pyasn1==0.2.3
cffi==1.10.0
pyasn1>=0.2.3
cffi>=1.10.0
sphinxcontrib-httpdomain==1.6.1
......@@ -29,6 +29,9 @@ v0.6.0
you'll have to manually upgrade/migrate your data `following this
documentation <https://github.com/tianon/docker-postgres-upgrade>`_.
- **BREAKING** - The ``docker-compose.yml`` file now uses the ``version: '2'``
format.
- **New** - Plugin system to enhance ACL and Authentication backends. See the
`Plugins <plugins.html>`__ documentation for details.
......@@ -36,6 +39,9 @@ v0.6.0
- **New** - Client configuration templates.
- **New** - Administration panel to manage both Authentications and
Authorizations.
v0.5.0
------
......
Flask==0.12.2
Flask-Login==0.4.0
Flask==0.12.4
Flask-Login==0.4.1
Flask-Bower==1.3.0
Flask-Babel==0.11.2
Flask-WTF==0.14.2
flask-restplus==0.10.1
Flask-Caching==1.3.3
Flask-Caching==1.4.0
WTForms==2.1
arrow==0.10.0
arrow==0.11.0
pluginbase==0.5
tzlocal==1.4
six==1.10.0
pyOpenSSL>=17.2.0
tzlocal==1.5.1
six==1.11.0
pyOpenSSL>=17.5.0
configobj==5.0.6
pyasn1>=0.2.3
cffi>=1.10.0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment