Commit 0705fa00 authored by Ziirish's avatar Ziirish

releasing CID 1.1.6

parent 91a41794
......@@ -43,7 +43,7 @@ set (bindir ${prefix}/bin)
########### project ###############
project ("cid")
set (VERSION "1.1.6-dev2")
set (VERSION "1.1.6")
add_definitions (-W -Werror -fno-builtin -g) #-Wunreachable-code -Wno-unused-parameter -Wall
if (NOT ${CMAKE_BUILD_TYPE})
......
......@@ -9,13 +9,15 @@ Les fenêtres étaient gérées par X, elles sont désormais gérées par GTK.
Pour compiler manuellement le programme, il vous faut certains paquets installés.
La liste des paquets necessaires est la suivante : libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev autoconf automake1.9 intltool libtool make libxml2-dev
La liste des paquets necessaires est la suivante : libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev cmake make libxml2-dev libcurl
Pour installer le programme, ./configure && make
Ensuite sudo make install
Pour compiler le programme, il faut utiliser cmake :
Si ça ne fonctionne pas, vous pouvez essayer un autoreconf -isvf avant le ./configure.
Si après ça, ça ne fonctionne toujours pas, envoyez moi un mail pour qu'on voit ça de plus près.
$ cd /where/is/cid
$ mkdir build && cd build
$ cmake [-DHAVE_COMPIZ="1"] [-DCMAKE_INSTALL_PREFIX=/usr] .. # par defaut le support de compiz n'est pas activé et le prefix est /usr/local
$ make
# make install
Pour le lancer, il ne vous reste plus qu'à taper cid --help pour obtenir les informations necessaires.
......@@ -28,13 +30,15 @@ Original projects are available here : http://forum.ubuntu-fr.org/viewtopic.php?
To compile by hand, you need some additional libs.
The list of needed package is : libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev autoconf automake1.9 intltool libtool make libxml2-dev
The list of needed package is : libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev cmake make libxml2-dev libcurl
To install the programm, type ./configure && make
Then type sudo make install
Then compile it using cmake:
$ cd /where/is/cid
$ mkdir build && cd build
$ cmake [-DHAVE_COMPIZ="1"] [-DCMAKE_INSTALL_PREFIX=/usr] .. # by default cid won't be compiled with the compiz support and the default prefix is /usr/local
$ make
# make install
If it does not work, you ca try autoreconf -isvf just before the ./configure.
If it still doesn't work, e-mail me so we can have a look together.
Now you can run the programm with the --help option (cid --help) to learn how to use it.
......@@ -42,11 +46,11 @@ Now you can run the programm with the --help option (cid --help) to learn how to
Resume/Summary
1. apt-get install libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev autoconf automake1.9 intltool libtool make libxml2-dev
1. apt-get install libdbus-1-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev cmake make libxml2-dev licburl
1.1. autoreconf -isvf
1.1. cd /where/is/cid; mkdir build && cd build
2. ./configure
2. cmake -DHAVE_COMPIZ="1" -DCMAKE_INSTALL_PREFIX=/usr ..
3. make
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment