Commit 5f30a8e6 authored by Ziirish's avatar Ziirish

automatically sync pkgs requirements with burp-ui's (fix #300)

parent 5fa69481
Pipeline #1590 passed with stages
in 5 minutes and 29 seconds
......@@ -11,12 +11,18 @@ Current
- Add: new ``bui-monitor`` processes pool + ``async`` backend to parallelize some requests `#278 <https://git.ziirish.me/ziirish/burp-ui/issues/278>`_
- Add: new `listen` and `listen_status` options in burp-2.2.10 `#279 <https://git.ziirish.me/ziirish/burp-ui/issues/279>`_
- Add: allow to hide selected clients/servers `#282 <https://git.ziirish.me/ziirish/burp-ui/issues/282>`_
- Fix: sync pkgs requirements with burp-ui's `#300 <https://git.ziirish.me/ziirish/burp-ui/issues/300>`__
- Fix: wrong command suggestion `#296 <https://git.ziirish.me/ziirish/burp-ui/issues/296>`__
- Fix: allow templates removal `#290 <https://git.ziirish.me/ziirish/burp-ui/issues/290>`__
- Fix: don't preload LDAP users `#270 <https://git.ziirish.me/ziirish/burp-ui/issues/270>`__
- Fix: issue `#268 <https://git.ziirish.me/ziirish/burp-ui/issues/268>`_
- `Full changelog <https://git.ziirish.me/ziirish/burp-ui/compare/0.6.0...master>`__
0.6.4 (03/26/2019)
------------------
- Fix: sync pkgs requirements with burp-ui's `#300 <https://git.ziirish.me/ziirish/burp-ui/issues/300>`__
0.6.3 (03/13/2019)
------------------
......
......@@ -12,6 +12,27 @@ from setuptools import setup, find_packages
# only used to build the package
ROOT = os.path.join(os.path.dirname(os.path.realpath(__file__)), '..', '..')
raw_requirements = [
'trio',
'arrow',
'tzlocal',
'pyOpenSSL',
'configobj',
]
requirements = []
try:
with open(os.path.join(ROOT, 'requirements.txt'), 'r') as req:
for line in req.readlines():
line = line.rstrip()
for i, look in enumerate(list(raw_requirements)):
if re.match(r'{}(=><)?'.format(look), line, re.IGNORECASE):
requirements.append(line)
del raw_requirements[i]
break
requirements += raw_requirements
except OSError:
pass
if 'sdist' in sys.argv or 'bdist' in sys.argv:
if not os.path.exists('burpui_agent'):
os.makedirs('burpui_agent', mode=0o0755)
......@@ -112,15 +133,7 @@ setup(
data_files=[
(confdir, [os.path.join(confdir, 'buiagent.sample.cfg')]),
],
install_requires=[
'trio==0.10.0',
'arrow==0.12.1',
'tzlocal==1.5.1',
'pyOpenSSL>=17.5.0',
'configobj==5.0.6',
'pyasn1>=0.2.3',
'cffi>=1.10.0',
],
install_requires=requirements,
classifiers=[
'Intended Audience :: System Administrators',
'Natural Language :: English',
......
......@@ -12,6 +12,27 @@ from setuptools import setup, find_packages
# only used to build the package
ROOT = os.path.join(os.path.dirname(os.path.realpath(__file__)), '..', '..')
raw_requirements = [
'trio',
'arrow',
'tzlocal',
'pyOpenSSL',
'configobj',
]
requirements = []
try:
with open(os.path.join(ROOT, 'requirements.txt'), 'r') as req:
for line in req.readlines():
line = line.rstrip()
for i, look in enumerate(list(raw_requirements)):
if re.match(r'{}(=><)?'.format(look), line, re.IGNORECASE):
requirements.append(line)
del raw_requirements[i]
break
requirements += raw_requirements
except OSError:
pass
if 'sdist' in sys.argv or 'bdist' in sys.argv:
if not os.path.exists('burpui_monitor'):
os.makedirs('burpui_monitor', mode=0o0755)
......@@ -112,13 +133,7 @@ setup(
data_files=[
(confdir, [os.path.join(confdir, 'buimonitor.sample.cfg')]),
],
install_requires=[
'trio==0.11.0',
'arrow==0.13.1',
'tzlocal==1.5.1',
'pyOpenSSL>=19.0.0',
'configobj==5.0.6',
],
install_requires=requirements,
classifiers=[
'Intended Audience :: System Administrators',
'Natural Language :: English',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment